Latest topics

» STA(Steel Tank Add-on) 3.2 (Steel Fury)
by lockie Yesterday at 1:42 pm

» The Sun Comes Up, the Sun Goes Down
by woofiedog Thu Nov 16, 2017 9:17 pm

» Variants of the "Sherman"
by mechanic Thu Nov 16, 2017 12:19 pm

» The Soviet Story
by Tanker Wed Nov 15, 2017 3:15 pm

» Легкий танк Т-50/Light tank T-50
by will73 Tue Nov 14, 2017 6:19 pm

» Campaign: Otto Carius (WIP)
by lockie Tue Nov 14, 2017 11:57 am

» Lieutenant Z. Kolobanova "To Stand to the Death!" Battle of Voiskovitsy
by frinik Tue Nov 14, 2017 1:08 am

» Ukraine fights against enemy.
by lockie Mon Nov 13, 2017 2:17 pm

» Video from SF
by geoweb35 Mon Nov 13, 2017 1:00 pm

November 2017

MonTueWedThuFriSatSun
  12345
6789101112
13141516171819
20212223242526
27282930   

Calendar Calendar


    Mission opens in ME but not game

    Share
    avatar
    KurtTank
    Silver Tools
    Silver Tools

    Posts : 385
    Join date : 2015-06-11
    Age : 57
    Location : Kalispell, Montana USA

    Mission opens in ME but not game

    Post by KurtTank on Tue Jan 31, 2017 5:02 pm



    Error loading mission (just a test mission for my desant work) just past 89% in game loading, but opens okay in the ME. confused

    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1395
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: Mission opens in ME but not game

    Post by frinik on Wed Feb 01, 2017 4:06 pm

    Check if there's not a missing line in the user_camp.engcfg .If your mission's name is not listed at the end of the paragraph then it won't load.
    avatar
    KurtTank
    Silver Tools
    Silver Tools

    Posts : 385
    Join date : 2015-06-11
    Age : 57
    Location : Kalispell, Montana USA

    Re: Mission opens in ME but not game

    Post by KurtTank on Thu Feb 02, 2017 12:01 am



    frinik wrote:Check if there's not a missing line in the user_camp.engcfg .If your mission's name is not listed at the end of the paragraph then it won't load.

    Don't think that's it.....it loads into the ME. Here is the line:

    user1()
    {
    A Unit Tester, A Unit Tester, 1, 0, tiger II barrel.jpg, txt_cit_02, 30, txt_hist_intro, hist_map_teach, levels\levels\cm_users\A Unit Tester.level;


    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1395
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: Mission opens in ME but not game

    Post by frinik on Thu Feb 02, 2017 3:29 pm


    You are correct. I was merely reminding you to check that.

    Then the cause is likely a new sound or possibly a modification to the mission editor ( new models).

    Did you modify any of the tank you are testing like the Tiger II for example? Modifying something in the tech_cfg?
    avatar
    KurtTank
    Silver Tools
    Silver Tools

    Posts : 385
    Join date : 2015-06-11
    Age : 57
    Location : Kalispell, Montana USA

    Re: Mission opens in ME but not game

    Post by KurtTank on Thu Feb 02, 2017 4:23 pm



    frinik wrote:
    You are correct. I was merely reminding you to check that.
    Thanks, sometimes a reminder is good, I'm open to any suggestions!

    frinik wrote:Then the cause is likely a new sound or possibly a modification to the mission editor ( new models).

    Did you modify any of the tank you are testing like the Tiger II for example? Modifying something in the tech_cfg?
    I have created new desant units and that is certainly the issue. I hate to take it all out, so I'll investigate the tech_config file, maybe I can figure it out.


    New unit:


    avatar
    KurtTank
    Silver Tools
    Silver Tools

    Posts : 385
    Join date : 2015-06-11
    Age : 57
    Location : Kalispell, Montana USA

    Re: Mission opens in ME but not game

    Post by KurtTank on Thu Feb 02, 2017 4:24 pm



    Still confused why it opens in the ME, but not the game.

    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1395
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: Mission opens in ME but not game

    Post by frinik on Fri Feb 03, 2017 4:16 am

    One easy way to find out is to take the unmodified tech_cfg file from another installation and put it into the installation you are using for testing or modifications. Then launch your test mission and see if it crashes.
    avatar
    KurtTank
    Silver Tools
    Silver Tools

    Posts : 385
    Join date : 2015-06-11
    Age : 57
    Location : Kalispell, Montana USA

    Re: Mission opens in ME but not game

    Post by KurtTank on Fri Feb 03, 2017 5:32 am



    frinik wrote: One easy way to find out is to take the unmodified tech_cfg file from another installation and put it into the installation you are using for testing or modifications. Then launch your test  mission and see if it crashes.

    I am working on that now. The new stuff I've been working on is the only thing crashing....now to figure out why!

    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1395
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: Mission opens in ME but not game

    Post by frinik on Sat Feb 04, 2017 3:54 am

    Or it could be as minutes as  a ; or , missing in one of the files that you modified,

    Are you using program such as "File Compare "to verify you new modified files side-by-side with the original ones? Very useful as it helps you narrow down the problem that would take hours to identify. Taha's what I use. Here's the download link:

    http://download.cnet.com/Files-Compare-Tool/3000-2248_4-10315688.html
    avatar
    KurtTank
    Silver Tools
    Silver Tools

    Posts : 385
    Join date : 2015-06-11
    Age : 57
    Location : Kalispell, Montana USA

    Re: Mission opens in ME but not game

    Post by KurtTank on Sat Feb 04, 2017 2:29 pm



    frinik wrote:Or it could be as minutes as  a ; or , missing in one of the files that you modified,

    Are you using program such as "File Compare "to verify you new modified files side-by-side with the original ones? Very useful as it helps you narrow down the problem that would take hours to identify. Taha's what I use. Here's the download link:

    http://download.cnet.com/Files-Compare-Tool/3000-2248_4-10315688.html

    Thanks, I'll give it a shot! And yes, I have spent hours comparing the files to no avail. I'll try this, maybe there's something I missed.


    Sponsored content

    Re: Mission opens in ME but not game

    Post by Sponsored content


      Current date/time is Sat Nov 18, 2017 9:40 am