December 2017

MonTueWedThuFriSatSun
    123
45678910
11121314151617
18192021222324
25262728293031

Calendar Calendar


    Pz Mk IV Ausf H

    Share

    dwain7

    Posts : 91
    Join date : 2016-04-12

    Pz Mk IV Ausf H

    Post by dwain7 on Wed Apr 20, 2016 5:27 am

    I have noticed what appears to be a "bug" in the STA Game Pack version of the PkW Mk IV Ausf H.  The "load main gun" player control (joystick button 3 for me) results in a tank commander order to "Stop Loading" -- every time.  The main gun simply will not load.  I went through every missions in all three STA game packs featuring the MK IV Ausf H and got the same result every time.  Other versions of the MK IV (Ausf F, for example) work just fine.  

    Is the above problem above isolated to my Steel Fury install, or has anyone else seen a similar problem?  I will confess that I do not have the IT "smarts" to puzzle out this problem.  I searched the STA forum for anything related to this bug, with no result.  Anyone who has seen this before or has an idea what the fix might be is very welcome.

    Thank you and best regards,
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1412
    Join date : 2014-07-27
    Age : 61
    Location : Bogota-Colombia

    Re: Pz Mk IV Ausf H

    Post by frinik on Wed Apr 20, 2016 9:42 am

    Yeah it's a bug in the common res or tech_cfg file most likely.I had that p[roblerm a while ago and solved it and I posted about it.


    Here it is below. It took me 2 minuets but I found it.It's dated 29 November 2015.Are you sure you searched the forum? Wink


    I found a bug which I corrected. Not sure if it's mine installation or STA 2.0 which has been remarkably bug-free so far. The Panzer IV H both green and yellow would not load shells at all. The poor things were getting killed without being able to shoot back. I checked the tech_cfg files and all entries were fine. Opening the Common Res I found that the entries for the KWk40 L48 gun and for the PZGR 39 and 40 shells were qquite different form the July 2015 update which I had been using. I removed the L$8 at the end the KwK 40 gun entry and replaced the lines Pzgr 39 & 40. I had with those from the July update and I am happy to report that the problem is now corrected and the PZIV H load shells now bite back! Smile

    There also seems to be a problem with the various MGs being used by the US tanks. I have 3 different sound entries for the M2hb and 4 for the M19a??? Some seem to conflict and cause random crashes. Why do we need so many different variants?

    Otherwise this is a work of art signed Master Lockie as Kapellmeister ! cheers

    PS: after further testing I can confirm that the bug with the Panzer IV H shells not loading is due to the presence of the L48 at the end of the PzrIV Lwk 40L48 gun entry in the common res  :
    //PzIVH
    KWK40L48,%FL_GUNBRAKE%,%WEAP_RBARRET%,48,75,0.6,0.48,0.25,1,1,0,6,1,1,1.5,shot_kwk40,reload1,,drop1,1,txt_gun_kwk40,gunbr_shot_pat,,KWK40L48;

    All you need to do is remove the L48 part( and save please!) at the end of the line :

    //PzIVH
    KWK40L48,%FL_GUNBRAKE%,%WEAP_RBARRET%,48,75,0.6,0.48,0.25,1,1,0,6,1,1,1.5,shot_kwk40,reload1,,drop1,1,txt_gun_kwk40,gunbr_shot_pat,,KWK40;

    and bingo your Panzer IV H will have its shell complement appearing on the shell load window ( bottom left side of your mission screen when playing a mission)and the shells will be loa

    Frinik

    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Wed Apr 20, 2016 10:23 am

    Thank you. I searched through the forum for a solution, for two days, and elsewhere on the net without success. Some things just are not intuitive, at least for me anyway. Believe me, I searched.

    Now, I must plead absolute unconditional no excuses ignorance...Can you please tell me the complete navigation path within Steel Fury to:

    //PzIVH KWK40L48,%FL_GUNBRAKE%,%WEAP_RBARRET%,48,75,0.6,0.48,0.25,1,1,0,6,1,1,1.5,shot_kwk40,reload1,,drop1,1,txt_gun_kwk40,gunbr_shot_pat,,KWK40L48;

    In all honesty I am not a IT person per se. And, is it the L48 at the end of the KWK40L48, %.... that needs to be deleted. or where is it?
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1412
    Join date : 2014-07-27
    Age : 61
    Location : Bogota-Colombia

    Re: Pz Mk IV Ausf H

    Post by frinik on Wed Apr 20, 2016 8:24 pm

    NO need to be a computer  expert( I definitely ain't one) just resourceful or inquisitive. Do not fear to explore your game.

    OK open you game folder  go to:( here's the path for one of my installations)


    E:\sf beta STA 2.0 Version 2\data\k42\loc_rus\levels\LEVELS\common

    Inside the Common folder you'll find file called common_ res.encfg. Open it with notepad. Go the

    weapons() entry.Look for the line below:


    //PzIVH
    KWK40L48,%FL_GUNBRAKE%,%WEAP_RBARRET%,48,75,0.6,0.48,0.25,1,1,0,6,1,1,1.5,shot_kwk40,reload1,,drop1,1,txt_gun_kwk40,gunbr_shot_pat,,KWK40;

    [b]IF YOU SEE AN L48AT THE END OF THAT LINE JUST ERASE IT AND SAVE.[/b]


    Last edited by frinik on Wed Apr 20, 2016 11:30 pm; edited 1 time in total

    Tanker
    TSF Member
    TSF Member

    Posts : 379
    Join date : 2014-07-28

    Re: Pz Mk IV Ausf H

    Post by Tanker on Wed Apr 20, 2016 9:11 pm

    Before:
    //PzIVH KWK40L48,%FL_GUNBRAKE%,%WEAP_RBARRET%,48,75,0.6,0.48,0.25,1,1,0,6,1,1,1.5,shot_kwk40,reload1,,drop1,1,txt_gun_kwk40,gunbr_shot_pat,,KWK40L48;

    After:
    //PzIVH KWK40L48,%FL_GUNBRAKE%,%WEAP_RBARRET%,48,75,0.6,0.48,0.25,1,1,0,6,1,1,1.5,shot_kwk40,reload1,,drop1,1,txt_gun_kwk40,gunbr_shot_pat,,KWK40L48;
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3791
    Join date : 2014-07-25
    Age : 50
    Location : Ukraine, Kyiv

    Re: Pz Mk IV Ausf H

    Post by lockie on Thu Apr 21, 2016 3:21 am

    dwain7, could u upload the next two original files:
    - ...\data\k42\loc_rus\levels\LEVELS\common\common_res.engcfg
    - ...\data\k42\loc_rus\levels\LEVELS\tech_cfg\pz4.engcfg
    Then I'll prepare the quick fix and u'll see how it works.
    U may upload here: sendspace.com/

    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Thu Apr 21, 2016 5:02 am

    Frinik, Tanker, thank you so much, but that did not work.

    Lockie, I have uploaded the two files you asked for.

    Best regards,
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3791
    Join date : 2014-07-25
    Age : 50
    Location : Ukraine, Kyiv

    Re: Pz Mk IV Ausf H

    Post by lockie on Thu Apr 21, 2016 11:21 am

    dwain7 wrote:Lockie, I have uploaded the two files you asked for.
    Where is the link? bounce

    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Thu Apr 21, 2016 5:31 pm


    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Thu Apr 21, 2016 5:33 pm

    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3791
    Join date : 2014-07-25
    Age : 50
    Location : Ukraine, Kyiv

    Re: Pz Mk IV Ausf H

    Post by lockie on Thu Apr 21, 2016 6:47 pm

    I've used mentioned link.
    Here's fix:
    sendspace.com 66rurv
    Install the last in line.

    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Fri Apr 22, 2016 4:25 am

    Lockie, I downloaded and installed the fix. The main gun still will not load.

    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Fri Apr 22, 2016 5:21 am

    I have also noticed that the shell selections (cycle between AP, HE, etc) is not working either.
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1412
    Join date : 2014-07-27
    Age : 61
    Location : Bogota-Colombia

    Re: Pz Mk IV Ausf H

    Post by frinik on Fri Apr 22, 2016 9:19 am

    You need to post your tech_cfg and common res file Dwain. IT 's probably something minor in either one of them.

    Check these paragraphs in your tech_cfg for the Panzer IV H and see if they similar to mine posted below:

    //îðóæèå
    weapons()
    {
    //íàçâàíèå, ÷àíê âûëåòà, ÷àíê îòêàòà, áàøíÿ èç êîòîðîé ñòðåëÿþò, ðàáî÷åå ìåñòî çàðÿæàþùåãî
    KWK40L48, s_gun, db_gun, head1, wp_loader, , 0.1, 0, 1, 0;
    MG34, s_mgun_02, , head1, wp_loader;
    MG34, s_mgun_01, , head2, wp_mgunner;
    }

    //áîåêîìïëåêò 87
    shells()
    {
    //èìÿ ñíàðÿäà, êîëè÷åñòâî
    PZGR39_75, 40, 0, 0;
    PZGR40_75, 0, 0, 0;
    SPRGR38_75, 47, 0, 1;


    BUL_792, 3350;
    }

    //áàøíè
    heads()
    {
    //íàçâàíèå, ÷àíê áàøíè, ÷àíê ïóøêè
    //óãîë ïîâîðîòà âëåâî - âïðàâî, óãîë ïîâîðîòà ââåðõ - âíèç,
    //ñêîðîñòü ïîâîðîòà ïî ãîðèçîíòàëè - âåðòèêàëè, -//- äëÿ ýëåêòðî ïðèâîäà (ãðàä/ñåê)
    head1, db_head, d_mask, 180, 180, 20, 8, 30, 5, 30, 0;
    head2, d_mgun_head, d_mgun_01, 12, 12, 6, 6, 30, 10, 30, 10;

    }

    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Fri Apr 22, 2016 9:43 am

    They were not similar, so (after making a back-up of the original) I deleted the similar (but not so similar lines) from the file and copy/pasted your lines in the same place. Still will not load or allow ordinance selection. The bug is elsewhere, I think.

    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Fri Apr 22, 2016 9:50 am

    Frenik, I uploaded the tech_cfg and common res files to the site Lockie pointed me to, and downloaded his recommended fix. No positive result. If there is a location you would like me to post the two file to, please advise and I will do so. Meanwhile, here are the relevant entries from both files in their current condition:

    Common res:

    KWK40L48,%FL_GUNBRAKE%,%WEAP_RBARRET%,48,75,0.6,0.48,0.25,1,1,0,6,1,1,1,shot_kwk40,reload1,,drop1,1,txt_gun_kwk40,gunbr_shot_pat,,KwK40;

    Tech_config/pz4.engcfg:

    //îðóæèå
    weapons()
    {
    //íàçâàíèå, ÷àíê âûëåòà, ÷àíê îòêàòà, áàøíÿ èç êîòîðîé ñòðåëÿþò,

    ðàáî÷åå ìåñòî çàðÿæàþùåãî
    KWK40, s_gun, db_gun, head1, wp_loader, s_klin, 0.1, 0, 1, 0;
    MG34, s_mgun, , head1, wp_loader, , , -1, -1, 0;
    MG34, s_mgun1, , head2, wp_mgunner;
    }

    //áîåêîìïëåêò 87
    shells()
    {
    //èìÿ ñíàðÿäà, êîëè÷åñòâî
    PZGR39_75, 35, 0, 0;
    PZGR40_75, 5, 0, 0;
    SPRGR38_75, 45, 0, 1;
    GR38HLB_75, 5, 0, 2;

    BUL_792, 3150;
    }

    //áàøíè
    heads()

    {
    //íàçâàíèå, ÷àíê áàøíè, ÷àíê ïóøêè
    //óãîë ïîâîðîòà âëåâî - âïðàâî, óãîë ïîâîðîòà ââåðõ - âíèç,
    //ñêîðîñòü ïîâîðîòà ïî ãîðèçîíòàëè - âåðòèêàëè, -//- äëÿ ýëåêòðî ïðèâîäà

    (ãðàä/ñåê)
    head1, db_head, d_mask, 180, 180, 20, 8, 30, 5, 30, 0;
    head2, d_mgun_head, d_mgun_01, 12, 12, 6, 6, 30, 10, 30, 10;

    }
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3791
    Join date : 2014-07-25
    Age : 50
    Location : Ukraine, Kyiv

    Re: Pz Mk IV Ausf H

    Post by lockie on Fri Apr 22, 2016 3:12 pm

    dwain7 wrote:Lockie, I downloaded and installed the fix.  The main gun still will not load.
    OK, then let's try the next version fix01_shell_PzIVH
    Here's link:
    sendspace.com efy64q

    1. Remove old fix
    2. Install new version fix01_shell_PzIVH the last in line.
    Also, upload here the picture with current installation. U may use this resource: http://postimg.org/
    I need to know what the mission do u play with Pz.IV H?
    There are two Pz.IV models:
    - green camo
    - yellow camo

    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Sat Apr 23, 2016 1:54 am

    OK, I installed the second fix (fix01_shell_PzIVH), and the problem still remains. Shell will not load. In gunner's mode scope view there is an unidentified (no information given) shell showing in the lower left panel (where you normally see available shells). I have also noticed that I cannot cycle between shell types either, i.e. cannot select between AP, HE, etc.

    I have been using the mission Final Cut, 1945 from GPM 3.32 as the test bed for this problem. However, I have also tried running all other missions is all three game packs that feature the PzIVH has the player's tank...Same result.

    I assume that when you asked for a picture of my installation you meant a picture of the JSGME view of the activated mods. I have posted that picture to the link you provided, and you can access it here:

    http://postimg.org/image/42x3b6vlz/

    If you meant any other installation picture, please advise.

    Thank you and best regards,
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3791
    Join date : 2014-07-25
    Age : 50
    Location : Ukraine, Kyiv

    Re: Pz Mk IV Ausf H

    Post by lockie on Sat Apr 23, 2016 2:26 am

    dwain7 wrote:
    I assume that when you asked for a picture of my installation you meant a picture of the JSGME view of the activated mods.  I have posted that picture to the link you provided, and you can access it here:
    http://postimg.org/image/42x3b6vlz/
    I don't see the fix confused
    Remove "turret displacing" and install the new fix. When u point the new mod u should see the name "fix01_shell_PzIVH".


    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Sat Apr 23, 2016 4:54 am

    Success!!!

    Thank you very much. I can really appreciate how for you this simulation is a labor of love.
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1412
    Join date : 2014-07-27
    Age : 61
    Location : Bogota-Colombia

    Re: Pz Mk IV Ausf H

    Post by frinik on Sat Apr 23, 2016 9:27 am

    Hi Dwain, in the weapon's entry of the tech _cfg file your:

    KWK40, s_gun, db_gun, head1, wp_loader, s_klin, 0.1, 0, 1, 0;

    Mine by comparison:

    KWK40L48, s_gun, db_gun, head1, wp_loader, , 0.1, 0, 1, 0;

    You see the L48 missing in yours right after KWK40?

    That's probably what was causing your gun not to load. Thanks to Lockie's fix it's solved but I strongly suspect that it was the root of your problem.

    Good stuff!

    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3791
    Join date : 2014-07-25
    Age : 50
    Location : Ukraine, Kyiv

    Re: Pz Mk IV Ausf H

    Post by lockie on Sat Apr 23, 2016 10:59 am

    dwain7 wrote:Success!!!
    Thank you very much.  I can really appreciate how for you this simulation is a labor of love.
    Smile
    I think the problem caused mod "displacing turret".
    Remove "displacing turret" and fix01, then start the mission with Pz.IVH.

    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Sat Apr 23, 2016 8:53 pm

    The problem was occurring before I added the displacing turret mod. The PvIVH missions work fine now with the fix installed and the turret mod removed. I will not be reactivating the displacing turret mod.

    I did notice that the fix did not work if activated after SepUpd_2015. I deactivated SepUpd_2015, installed the fix after all three game packs, and then added SepUpd_2015 after the fix. Now everything works perfectly, for me anyway. My active mods in order of activation are SSM 2.3, STA 1.0 full, GPM 1, GPM 2, GPM 3, fix01_shell PzIVH, and SepUpd_2015.

    Thanks again.
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3791
    Join date : 2014-07-25
    Age : 50
    Location : Ukraine, Kyiv

    Re: Pz Mk IV Ausf H

    Post by lockie on Sat Apr 23, 2016 9:02 pm

    dwain7 wrote:
    I did notice that the fix did not work if activated after SepUpd_2015.
    Did u try to play the mission without "fix01" and "displacing turret"?
    Coz if u placed "fix01" before SepUpd - it doest that SepUpd overwrote the "fix01".

    dwain7

    Posts : 91
    Join date : 2016-04-12

    Re: Pz Mk IV Ausf H

    Post by dwain7 on Sat Apr 23, 2016 11:32 pm

    Well, PzIVH never worked until I installed the fix, and the problem was there before I ever installed the turret mod and subsequently the fix. For whatever reason, the fix did not work placed before SepUpd, only after. Bits and bytes...What do I know??

    Sponsored content

    Re: Pz Mk IV Ausf H

    Post by Sponsored content

      Similar topics

      -

      Current date/time is Sun Dec 17, 2017 4:05 pm