Latest topics

» Campaign "Steel Beast" (Pz.V "Panther") WIP
by mechanic Today at 12:29 pm

» Легкий танк Т-50/Light tank T-50
by will73 Yesterday at 10:00 pm

» Танк Пантера Д/А/Г/ Panther ausf.D,A,G
by lockie Yesterday at 5:52 pm

» il2 Sturmovik Stalingrad
by lockie Yesterday at 3:51 pm

» SF STA1.2 demo version?
by woofiedog Sun Nov 19, 2017 3:30 pm

» Video from SF
by geoweb35 Sun Nov 19, 2017 11:24 am

» How to get STA3.2 mod?
by lockie Sat Nov 18, 2017 6:18 pm

» STA(Steel Tank Add-on) 3.2 (Steel Fury)
by lockie Fri Nov 17, 2017 1:42 pm

» The Sun Comes Up, the Sun Goes Down
by woofiedog Thu Nov 16, 2017 9:17 pm

November 2017

MonTueWedThuFriSatSun
  12345
6789101112
13141516171819
20212223242526
27282930   

Calendar Calendar


    New install, need help on enabling Anti-aliasing?

    Share

    minimi66
    TSF Member
    TSF Member

    Posts : 66
    Join date : 2014-11-10

    New install, need help on enabling Anti-aliasing?

    Post by minimi66 on Sun Feb 21, 2016 3:30 pm

    Hi everyone,

    I'm just in the process of re-installing SF-K42 with STA 1.0 etc. on a new computer.

    Everything going fine so far but i'm trying to follow the posted instructions to enable Anti-aliasing.  I have used the image of lockie's settings posted here:

    http://stasf2008.ephpbb.com/t115-antialiasing

    so my nVidia  Inspector settings are:



    My question is, how do i actually know that AA is enabled as there doesn't seem to be a great difference in what i'm seeing post-AA enabling and with what i had before in default non-AA setting?

    Here are some screenshots of what i'm currently seeing:









    I'm running an nVidia GTX 980 4GB video card on a i7 4790 3.6 GHz CPU. Asus ROG G20 desktop 8 GB RAM.  Resolution 1920 x 1080 @ 60Hz.  Have followed all the posted install and setup instructions regarding In Game Video and Display settings (uncheck "Use Desktop Resolution" etc.)  Anisotropic Filtering is set in game settings at '5'.

    Any help much appreciated?

    Thanks guys, can't wait to get back into this game again!  Very Happy

    minimi66
    TSF Member
    TSF Member

    Posts : 66
    Join date : 2014-11-10

    Re: New install, need help on enabling Anti-aliasing?

    Post by minimi66 on Sun Feb 21, 2016 3:59 pm

    Here is a shot of my video settings file, looks to me like AA is NOT enabled in this file i.e. both type and quality are set at 0?



    thanks.

    minimi66
    TSF Member
    TSF Member

    Posts : 66
    Join date : 2014-11-10

    Re: New install, need help on enabling Anti-aliasing?

    Post by minimi66 on Sun Feb 21, 2016 4:45 pm

    No need to reply to this thread, am happy now AA is working and graphical quality is as it was on my previous PC.
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: New install, need help on enabling Anti-aliasing?

    Post by lockie on Sun Feb 21, 2016 4:56 pm

    Hi, minimi66
    Can't help myself to make a note.
    U've a very good specification: GTX 980 4GB video card on a i7 4790 3.6 GHz CPU. Asus ROG G20 desktop 8 GB RAM
    BUT er image adjusting has a very poor level. AA should be 8x, Aniso 16x.
    Also STA2.0 will get some features, which increase graphic requests with a good hardware. In er case, that would be ideal!
    Anyway, good luck in hunter! Cool Basketball

    minimi66
    TSF Member
    TSF Member

    Posts : 66
    Join date : 2014-11-10

    Re: New install, need help on enabling Anti-aliasing?

    Post by minimi66 on Sun Feb 21, 2016 5:03 pm

    Thanks lockie,

    I will adjust those settings, try them out and look forward to STA 2.0 !!
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: New install, need help on enabling Anti-aliasing?

    Post by frinik on Sun Feb 21, 2016 7:36 pm

    Minimi66 I can't help but note that your grass looks crappy. Let's fix this.Go to your config file Here's how to get there:
    E:\sf beta STA 2.0 Version 2\data\k42\loc_rus\config

    Open your config file with notepad and adjust the following entry like this below( use the values posted):

    //ìåíåäæåð ðàñòèòåëüíîñòè
    i_plantman:plantman()
    {
    //òðèìèíã ðàñòèòåëüíîñòè (0 - âûêë, 1 - óäàëèòü ÷àñòü ðàñòèòåëüíîñòè)
    flora_trim = 0.000000;
    //àäàïòèâíûé âûáîð ëîä óðîâíÿ ðàñòèòåëüíîñòè (0 - âûêë, 1 - ìàêñèìàëüíàÿ ñêîðîñòü)
    adapt_ls = 0.500000;
    //òðèìèíã ðàñòèòåëüíîñòè (0 - âûêë, 1 - óäàëèòü ÷àñòü ðàñòèòåëüíîñòè)
    flora_trime = 0.500000;

    }// end of i_plantman:plantman

    Then save and exit and see the difference. With your beast of a pc no worries this won't even make it sweat.


    minimi66
    TSF Member
    TSF Member

    Posts : 66
    Join date : 2014-11-10

    Re: New install, need help on enabling Anti-aliasing?

    Post by minimi66 on Mon Feb 22, 2016 11:16 am

    Hi frinik,

    Thanks for the tip but it would seem that someone else got there first? My file already has those settings you posted:

    i_plantman:plantman()
    {
    //триминг растительности (0 - выкл, 1 - удалить часть растительности)
    flora_trim = 0.000000;
    //адаптивный выбор лод уровня растительности (0 - выкл, 1 - максимальная скорость)
    adapt_ls = 0.500000;
    //триминг растительности (0 - выкл, 1 - удалить часть растительности)
    flora_trime = 0.000000;

    }// end of i_plantman:plantman

    Will dive into SF now and take some more screenies, maybe there is something else i can tweak or maybe the 8x AA and 16x Aniso settings from lockie's comment above will have made a difference?

    Be right back!

    Thanks.

    minimi66
    TSF Member
    TSF Member

    Posts : 66
    Join date : 2014-11-10

    Re: New install, need help on enabling Anti-aliasing?

    Post by minimi66 on Mon Feb 22, 2016 12:25 pm

    Hi lockie,

    Tried changing up the AA and Aniso settings but it crashed my whole system to reboot every time i started the game?? Changed settings back to 4 and 8 and all worked ok again.

    Which exact 8 and 16 settings do you recommend as there are several at each setting as you know?

    I'm currently using 4 [4x Multisampling] for AA and plain 8x for Aniso.

    Believe i changed them to:

    8xQ [8x Multisampling]

    and

    16x

    Any thoughts?

    Thanks.

    minimi66
    TSF Member
    TSF Member

    Posts : 66
    Join date : 2014-11-10

    Re: New install, need help on enabling Anti-aliasing?

    Post by minimi66 on Mon Feb 22, 2016 1:09 pm

    With current settings:







    Should i be getting better than this guys? Grass or otherwise?

    thanks Smile

    minimi66
    TSF Member
    TSF Member

    Posts : 66
    Join date : 2014-11-10

    Re: New install, need help on enabling Anti-aliasing?

    Post by minimi66 on Mon Feb 22, 2016 2:11 pm

    I think looking at my screenies from yesterday i've answered my own question? All is good!!
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: New install, need help on enabling Anti-aliasing?

    Post by frinik on Mon Feb 22, 2016 3:13 pm

    Good stuff !Now checked that other entry ( it defines the quantity of foliage and vegetation and details on your maps)and make sure it's sim ilar to that one below:

    //òðàâà
    i_microman:microman()
    {
    //äàëüíÿÿ ãðàíèöà ìèêðîîáúåêòîâ, ì (128.0 - 1024.0)
    micro_dist = 150.000000;
    //âåëè÷èíà ñìåùåíèÿ ëîäîâ òðàâû (0.0 íå ñìåùàåòñÿ - 1.0 âñåãäà ïîñëåäíèé ëîä)
    micro_lods = 0.000000;
    //òðèìèíã ìèêðî îáúåêòîâ (0 - âûêë, 1 - óäàëèòü âñþ òðàâó)
    micro_trim = 0.000000;

    }// end of i_microman:microman
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: New install, need help on enabling Anti-aliasing?

    Post by lockie on Mon Feb 22, 2016 4:35 pm

    minimi66 wrote:
    Tried changing up the AA and Aniso settings but it crashed my whole system to reboot every time i started the game?
    That's strange, it should work.
    It is possible to increase the distance for the LODs(Level Of Detail). Open with Notepad++ this file:
    ...data\k42\loc_rus\config\config.engcfg
    Make changes in these entries:
    lod_dist0 = 25.000000;
    lod_dist1 = 150.000000;
    lod_dist2 = 0.000000;
    to
    lod_dist0 = 750.000000;
    lod_dist1 = 1000.000000;
    lod_dist2 = 500.000000;
    Save.
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: New install, need help on enabling Anti-aliasing?

    Post by frinik on Mon Feb 22, 2016 8:06 pm

    Does it result in less or more details if you increase the LODs like you are recommending?
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: New install, need help on enabling Anti-aliasing?

    Post by lockie on Mon Feb 22, 2016 8:55 pm

    I may promise it'll greatly overload PC! I think 3 times more! But u may see detailed 1 LOD at distance 750m
    I've adjusted to 50m.
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: New install, need help on enabling Anti-aliasing?

    Post by frinik on Tue Feb 23, 2016 5:01 am

    Out of curiosity I adjusted my values based on what you posted Lockie and I was able to play a tank heavy mission at 36 to 41 fps. Just to be sure I will repeat the experiment and try the same mission with old values and the new ones and compare the fps. My own conclusion is that Steel Fury is very taxing for the cpu because it's not well optimized and your cpu ( the one I use is an i7 4700 Q for notebook 2.4ghz which can reach 2.6ghz with Asus cpu booster. However whenever you increase the graphic details it puts more load on the gpu . I have a good gpu, an Nvidia GTX 860M ( notebook version equivalent to a 750 ti desktop one), which can deliver the goods and that may be why increasing the detail does not necessarily leads to a drop in fps if you have a good cpu-gpu combo.
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: New install, need help on enabling Anti-aliasing?

    Post by frinik on Tue Feb 23, 2016 3:43 pm

    I did an experiment. I chose a tank heavy mission and I played it with Lockies's suggested values : 750, 1000 , 500.The fps from a third person view( external camera) were from 21 to 26 with lows to 12.When using the gun sight the fps would increase to 30 /32. Visually I did not notice a huge difference compared to what I had with my default values, 50, 150, 0 .I decided to paly the same mission decreasing the values to 150, 500 and 100. The fps increased third person view by 40% to minimum 25 to 32 while when using the gun sight only a  little difference 32-34. Finally I decreased the values to 50 , 300 and 50 and got from 28 to 34 fps third person view and 32 to 36 using the gun sight.

    Conclusion: increasing the value as suggested by Lockie does have a strong impact on fps. The benefits are not obvious and even if you have  a beast of a pc there are more cons than pros. For those with medium to low specs no benefit and a heavy penalty in terms of choppier gameplay.

    Lowering the values to the last I suggested seems a reasonable compromise: a little improvement in visual quality and details with virtually no penalty in fps.


    Last edited by frinik on Tue Feb 23, 2016 5:38 pm; edited 2 times in total
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: New install, need help on enabling Anti-aliasing?

    Post by lockie on Tue Feb 23, 2016 3:48 pm

    frinik wrote:I did an experiment. I chose a tank heavy mission
    That's indeed a very interesting experiment! Just wonder, what the "heavy mission" is? As my point it is "Destroy the Fatherland".
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: New install, need help on enabling Anti-aliasing?

    Post by frinik on Tue Feb 23, 2016 5:36 pm

    It's one of mine; a user-made mission with 51 tanks, some infantry and apcs on the Izum map.
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: New install, need help on enabling Anti-aliasing?

    Post by lockie on Tue Feb 23, 2016 8:07 pm

    frinik wrote:It's one of mine; a user-made mission with 51 tanks, some infantry and apcs on the Izum map.
    What abt. to make er mission as a standard to calculate fps? Suppose 4xInf. platoon will be enough to get the hardest level.
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: New install, need help on enabling Anti-aliasing?

    Post by frinik on Wed Feb 24, 2016 12:53 am

    It all depends on your specs Lockie. Some have monster pcs with GTX980s and I7 Haswell processors. I have an average Asus gaming laptop with solid specs but nothing really earth shattering . Others have pcs or laptops with casual graphic specs not allowing them to run infantry heavy missions at reasonable framerates.

    Infantry and dust are fps killers in this game. In fact I can play Arma 2 or 3 or Battlefield 3 and 4 with all around high res and graphic quality at much better framerates and with better physics and graphic effects than Steel Fury.

    Sponsored content

    Re: New install, need help on enabling Anti-aliasing?

    Post by Sponsored content


      Current date/time is Tue Nov 21, 2017 10:34 pm