Latest topics

» Танк Пантера Д/А/Г/ Panther ausf.D,A,G
by will73 Today at 6:19 am

» What's the matter....
by woofiedog Yesterday at 8:18 pm

» New & Updated Models(Нові Моделі)
by lockie Yesterday at 11:31 am

» Ukraine fights against enemy.
by lockie Thu Aug 17, 2017 6:48 pm

» Elvis Presley
by woofiedog Wed Aug 16, 2017 11:34 pm

» Missing Keyboard Defaults
by PanzerLion Wed Aug 16, 2017 7:46 pm

» Question on music choice for American missions
by woofiedog Tue Aug 15, 2017 2:14 pm

» Attack Attack Atttack!
by woofiedog Tue Aug 15, 2017 1:55 pm

» Остови техніки/wrecked techniks
by will73 Tue Aug 15, 2017 12:34 am

August 2017

MonTueWedThuFriSatSun
 123456
78910111213
14151617181920
21222324252627
28293031   

Calendar Calendar


    Need help with mod installation

    Share

    FlyingNutcase

    Posts : 10
    Join date : 2015-10-08

    Need help with mod installation

    Post by FlyingNutcase on Fri Oct 09, 2015 6:48 am

    Hi guys,

    Somehow I missed this game over the years and just discovered it a few days ago (via some very cool vids on YouTube), a few days after discovering Steel Armor by chance on Steam. I also have the Operation Star series.

    Anyway, I've tried to do my homework with regard to the mods but I may have made a mis-turn already so thought it would be better to make a tactical pause than keep going up the wrong path.

    I've been following the directions on this page: http://stasf2008.ephpbb.com/t6-steel-tank-add-on-steel-fury

    - I've got JSGME in place okay.

    Questions
    1) Regarding:
    |00. Integrated patch link1, link2. It is MUST for non-English game version.
    |01. 10 polygons link1, link2, link3. It is MUST for non-English game version.

    Are these ONLY for non-English versions of the game? I enabled the integrated patch and got the menu in Russian, so disabled it.

    2) Regarding the "4Gb" patch
    I downloaded this and it's a 44Kb exe. Is that correct? I ran it and pointed it to "starter.exe" in the game folder. Is this correct?

    3) The text at the top of the screen is being cut off. I enabled "Wide-screen fix 16:9" patch but it seems to be the cause of "Exception core:
    001: Error initialization program.", which crashed the program.

    So not off to the best of starts really but as with everything, it's easy when you know how. Thanks for helping out and putting up with a newbie...
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3588
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: Need help with mod installation

    Post by lockie on Fri Oct 09, 2015 3:35 pm

    Hi, FlyingNutcase
    FlyingNutcase wrote:
    Questions
    1) Regarding:
    |00. Integrated patch link1, link2. It is MUST for non-English game version.
    |01. 10 polygons link1, link2, link3. It is MUST for non-English game version.
    Are these ONLY for non-English versions of the game?
    Yes Smile It's obvious. Why do u ask? Rolling Eyes
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1382
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: Need help with mod installation

    Post by frinik on Fri Oct 09, 2015 5:11 pm

    The menu in Russian is either due to an extra entry into the cd folder which you find here in your game

    F:\Steel Fury Installations\sf beta NTA 1.8 May Winter Mod 1.2\data\k42\loc_rus\cd

    Once you open the cd folder the last entry at the bottom should read tex_pack9.If it  doesn t and there s another entry after just delete that one and save and exit. Your game should normally all be in English now.

    If that doe snot solve your problem then go to the text folder:

    F:\Steel Fury Installations\sf beta NTA 1.8 May Winter Mod 1.2\data\k42\loc_rus\text

    inside open all 3 files called :

    loc_kits
    loc_kit_subs
    loc_kit_tools

    with notepad of word.

    The header on the top left side should read like this:

    loc_rus()
    {

    Just change it to loc_eng()
    {

    for each file and save.That should definitely solve your Russian language problem.

    FlyingNutcase

    Posts : 10
    Join date : 2015-10-08

    Re: Need help with mod installation

    Post by FlyingNutcase on Fri Oct 09, 2015 7:17 pm


    Yes Smile It's obvious. Why do u ask? Rolling Eyes

    @lockie: I asked because "It is MUST for non-English game version." leaves open the possibility that "It's optional for English game version." and being half Klingon, I needed to satisfy that part of me.

    @frinik: I'll bear that in mind; for now I've just removed that mod :-)

    Any feedback on #2 & #3?

    Velyke spasybi cyclops ~
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1382
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: Need help with mod installation

    Post by frinik on Sat Oct 10, 2015 4:19 am

    Flyingnut, re the 4 Gb patch I can't help you as I have 16GBs of RAM on my laptop and I don't need it but I wouldn't be surprised it's small. The best way is to execute the file.

    If it's not corrupt a small screen should open asking you which file you wish to patch( this is taken from my readings on for a where people used it and related their experience. Apparently it's really useful to have it if you pc has limited RAM .

    Re number 3) I was curious so I downloaded the Widescreen patch which I don't use as I don't have an issue with the wide screen. I installed it ( in fact rather than implement the patch I simply copied the 7 interf files in lieu of my own and tested .No crash my game started normally without issue but the interface of my menu is small now.

    My verdict I sincerely doubt the patch is causing your crash unless your mods are not in the p[roper order. This leads me to my next question what's your mod order. You need to post a pic of what the mods in your JSMG look like. I suspect incorrect order or conflicting mods are causing your exception core error message.

    SF is a very stable game but very fussy when it comes to file order unlike some other games or sims I play which are more accommodating. Un fortunately you can't use a mod installer like PlayforSIX or Steam.

    FlyingNutcase

    Posts : 10
    Join date : 2015-10-08

    Re: Need help with mod installation

    Post by FlyingNutcase on Sat Oct 10, 2015 10:23 am

    @frinik:
    Right, well you've clarified the "4Gb Patch" thing; much appreciated. I assumed it was a patch of 4GB of new game content. I've got 8GB RAM and a 2GB graphics card so should be fine there. So that's that one sorted. Getting momentum now!

    I've enabled:
    SSM2.1
    STA 1.0 full

    ...and am currently downloading
    STA_GMP_1.5
    STA_GMP_2.35
    STA+GMP_3.32
    JulUpd_2015

    I still have the cut off screen text but will have a fiddle with things tomorrow and see if I can get that sorted. The other thing is that the graphics are horrendous. I really hope that I can get it looking like some of the vids on YouTube. I have an AMD video card which I understand to be a disadvantage in terms of anti-aliasing. Time will tell.
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3588
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: Need help with mod installation

    Post by lockie on Sat Oct 10, 2015 11:05 am

    FlyingNutcase wrote:
    I've got 8GB RAM and a 2GB graphics card so should be fine there. So that's that one sorted.
    If u didn't install "4Gb Patch" then sooner or later u would get CTD. It doesn't matter how many memory do u've on the board: 8 or 16 or 32/128 etc.
    Read more details FAQ No2: 2. Q. What does "4Gb patch"? I have code 006 shader error while loading. How to get rid off this error?
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1382
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: Need help with mod installation

    Post by frinik on Sun Oct 11, 2015 5:21 am

    Actually my experience is that AMD cards perform better with SF than Nvidia. SF has never detected the correct vram memory of my Nividia video cards but always did detect correctly that for my ATI gpus.

    Re your ATI gpu make sure the game detects it and does not default to your intel gpu which is probably why your grahics are horrendous. Go into the CCC ( Catalyst control panel) and add SF to your list of games and make sure that the default gpu for your game is the ATI with dedicated graphic memory not the integrated one( intel). Nvidia' s Optimus works much better than its AMD counterpart. My desktop is equipped with an ATI HD 7750 1 gb of gddr5 and an intel i960 processor and 8 gbs of RAM and SF runs at 1920 X 1080 with AA and AF with good fps. No reason your rig can't do the same. What gpu do you have?

    FlyingNutcase

    Posts : 10
    Join date : 2015-10-08

    Re: Need help with mod installation

    Post by FlyingNutcase on Sun Oct 11, 2015 10:43 am

    frinik wrote:Actually my experience is that AMD cards perform better with SF than Nvidia. SF has never detected the correct vram memory of my Nividia video cards but always did detect correctly that for my ATI gpus.

    Re your ATI gpu make sure the game detects it and does not default to your intel gpu which is probably why your grahics are horrendous. Go into the CCC ( Catalyst control panel) and add SF to your list of games and make sure that the default gpu for your game is the ATI with dedicated graphic memory not the integrated one( intel). Nvidia' s Optimus works much better than its AMD counterpart. My desktop is equipped with an ATI HD 7750 1 gb of gddr5 and an intel i960 processor and 8 gbs of RAM and SF runs at 1920 X 1080 with AA and AF with good fps. No reason your rig can't do the same. What gpu do you have?

    @frinik:
    Hey, thanks for the feedback re graphics; much appreciated. My card is a Radeon HD6970 with 2GB GDDR5; processor is Core i7 2600K; 8GBs RAM on the motherboard.

    I've installed CCC but although SF is listed in the library, there doesn't seem to be any options for assigning graphics to it, or any other customisation. See screenshots below:

    1) SF in CCC


    2) In Game Graphics


    Cheers
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1382
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: Need help with mod installation

    Post by frinik on Sun Oct 11, 2015 4:00 pm

    UH this is not CCC on your post this is Raptr that you are showing! It has nothing to do with the CCC ( Catalyst Control Centre)which is an AMD/ATI software feature.

    Don't use Raptr,  it just does not recognise Steel Fury because that game is too old and unknown in the West. Likewise for Geforce Experience(Nvidia), it won't accept SF.

    The CCC or Catalyst Control Centre is the software program that normally comes automatically when you install drivers from AMD/ATI from their webpage. Even if you use Raptr to download your drivers you should get it as it's part of the driver's package. The equivalent for Nvidia calls is the Control Panel for their gpus . It allows you to set 3D graphic features to your game such as Anti aliasing, Vsync, Anisotropic filtering etc. Also you can chose which programs to run with the integrated graphics and which ones with the dedicated ATI gpu. Once you adjust these individually and test on your game you'll see how nice the game looks like. You have better specs video card-wise than mine.

    Here's an article form Tom's Hardware about it:

    http://www.tomsguide.com/us/catalyst-control-center,review-2012.html

    OK once you open your CCC you should see an option to add a program to the 3D graphic options. Just click on the .exe of your SF installation and it will be added to the list of games that you have. Once installed you can tailor the various options based on your preferences.

    FlyingNutcase

    Posts : 10
    Join date : 2015-10-08

    Re: Need help with mod installation

    Post by FlyingNutcase on Sun Oct 11, 2015 10:33 pm

    @frinik:
    Agh, indeed; it opened up with CCC.

    So is the following screenshot a step in the right direction:


    | It allows you to set 3D graphic features to your game such as Anti aliasing, Vsync, Anisotropic filtering etc.
    Those options seem to be available; any thoughts as to best settings? I've played around a bit with no improvement.

    | Also you can choose which programs to run with the integrated graphics and which ones with the dedicated ATI gpu.
    I'm not seeing where that is done.

    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1382
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: Need help with mod installation

    Post by frinik on Tue Oct 13, 2015 10:33 am

    I'll have to look at my installs on my desktop which comes equipped with an ATI HD 7750.

    I know that for laptops equipped with AMD APUs or GPUs there's an option ( switchable graphics I think it's called)to combine both integrated and dedicated.If your desktop intel cpus doe snto contain integrated graphics then in the CCC make sure you add your SF installation to the list a games in the 3D graphic( gaming )options. You'll have to adjust the settings on a trial and error basis.One thing though ; disable V sync. Enabling Vsync will not make the game prettier but it will drain graphic resources. For the AA and AF options I think for most I use the enhance game settings option. I will have to look at my graphic settings at home.  One good read about both graphic tweaks and settings for a variety of gpus ( both Nvidia and AMD/ATI) is excellent article. Read it it will help you for any game.


    http://www.tweakguides.com/Graphics_1.html

    Here's an article taken from AMD's own webpage on graphic tweaks for their video cards.

    http://support.amd.com/en-us/kb-articles/Pages/TroubleshootingGameIssues.aspx#five
    http://support.amd.com/en-us/kb-articles/Pages/TroubleshootingGameIssues.aspx#five

    Ok after posting that I went home and checked my July instal in  the CCC Here s what I have settings-wise:

    AA Mode  = Override appln settings
    AA Samples = none
    Filter = standard
    AA Method = multisampling
    Morph Filt. = on
    AF Mode =Use appln settings
    AF Level = use appln settings
    Texture Filt Quality = standard
    Surface Format Optimising = Off
    Wait for Verticla Refresh = always off
    Open GL = Off
    Tessalation Mode = AMD optimized
    Tessalation Meximum = AMD optimized

    I have an ATI HD 7750 1 gb ddr5 vram, an intel i7 960 2.8 ghz and 8 gbs of RAM. You have better specs so you could set high settings. Tinker with it and through trial and error until you get the best possible result for you.

    If you cannot get nice graphics it means your pc defaults SF to your intel graphics which explains why they are so ugly. You may want to try disabling your intel video card driver in the Device Manager.The game will have no choice but to default to your ATI video card since it will be the only one left working.

    FlyingNutcase

    Posts : 10
    Join date : 2015-10-08

    Re: Need help with mod installation

    Post by FlyingNutcase on Wed Oct 14, 2015 6:41 pm

    @frinik

    Firstly, I very much appreciate all the efforts you're making to get things working.

    Unfortunately even after replicating your settings, I get the same result. Below is a screenshot from the Device Manager's Display Adapters tree, which I guess is where one would look to disable the onboard graphics, but it just lists the graphics card.


    The graphics in Steel Armor are fine (Steam version). For now I've got to leave this until the weekend.
    avatar
    33lima
    TSF Member
    TSF Member

    Posts : 459
    Join date : 2014-07-27
    Location : Belfast, NI

    Re: Need help with mod installation

    Post by 33lima on Wed Oct 14, 2015 9:19 pm

    Under Steel Fury's 'Options', among other settings, are two check boxes: 'Use Desktop Resolution' and 'No Video Mode Restrictions'. Maybe try different combinations of these, ticked or unticked. You look to be stuck in a very low, default resolution and I seem to remember this happening to me before; IIRC these settings were the issue, tho I have an Nvidia 250 GTS so you may have the same symptom, but a different cause.

    I have 'Use Desktop Resolution' ticked and 'No Video Mode Restrictions' unticked. My desktop resolution is 1600x900 and I think this is what I now get in-game.

    FlyingNutcase

    Posts : 10
    Join date : 2015-10-08

    Re: Need help with mod installation

    Post by FlyingNutcase on Thu Oct 15, 2015 5:56 am

    33lima wrote:Under Steel Fury's 'Options', among other settings, are two check boxes: 'Use Desktop Resolution' and 'No Video Mode Restrictions'. Maybe try different combinations of these, ticked or unticked. You look to be stuck in a very low, default resolution and I seem to remember this happening to me before; IIRC these settings were the issue, tho I have an Nvidia 250 GTS so you may have the same symptom, but a different cause.

    I have 'Use Desktop Resolution' ticked and 'No Video Mode Restrictions' unticked. My desktop resolution is 1600x900 and I think this is what I now get in-game.

    @33lima
    Thanks for the input. Under Game Settings it says that I have less than 128MB RAM and that my system is under specs so may have artifacts etc. Trying to play IL2: Battle Over Stalingrad (modern flight sim) which usually runs smoothly, is all choppy. I think a fault with my graphics card or some system issue is the cause. I'll check it our at the weekend. In fact I've been wanting to do a reinstall of Windows, so this might be a good time.

    I'll report back after in a bit.

    Thanks all for your input. I look forward to playing this some time soon. :-)

    Sponsored content

    Re: Need help with mod installation

    Post by Sponsored content


      Current date/time is Sun Aug 20, 2017 9:04 am