Latest topics

» Campaign "Steel Beast" (Pz.V "Panther") WIP
by mechanic Today at 12:29 pm

» Легкий танк Т-50/Light tank T-50
by will73 Yesterday at 10:00 pm

» Танк Пантера Д/А/Г/ Panther ausf.D,A,G
by lockie Yesterday at 5:52 pm

» il2 Sturmovik Stalingrad
by lockie Yesterday at 3:51 pm

» SF STA1.2 demo version?
by woofiedog Sun Nov 19, 2017 3:30 pm

» Video from SF
by geoweb35 Sun Nov 19, 2017 11:24 am

» How to get STA3.2 mod?
by lockie Sat Nov 18, 2017 6:18 pm

» STA(Steel Tank Add-on) 3.2 (Steel Fury)
by lockie Fri Nov 17, 2017 1:42 pm

» The Sun Comes Up, the Sun Goes Down
by woofiedog Thu Nov 16, 2017 9:17 pm

November 2017

MonTueWedThuFriSatSun
  12345
6789101112
13141516171819
20212223242526
27282930   

Calendar Calendar


    Weird problem with sound settings

    Share

    Technopiper

    Posts : 144
    Join date : 2015-07-30

    Weird problem with sound settings

    Post by Technopiper on Fri Aug 07, 2015 1:31 pm

    Hi guys, I have a problem setting the speech volume. No matter my setting, in-game speech remains the same. Even when I set it to "0", I can still hear speech at 100% volume. Has anyone noticed that? I tried everything: disabling SSM, even reinstalling. I understand speech can be disabled by renaming the "speech" folder, but I just want to tone down its volume a bit.

    Another related problem. Graviteam says here: http://graviteam.com/forum/index.php?topic=4.0
    "In game options choose "disable sound and music", this also disable subtitles."
    I've found that you can disable subtitle by disabling sound all together. But what if I want to retain sound?
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: Weird problem with sound settings

    Post by lockie on Fri Aug 07, 2015 4:06 pm

    Suppose, this is a system problem. In case u've win 8 may be u need to adjust A/V receiver?
    From FAQ:
    19. Q. I do not hear any sounds, like engines or gunshots. Why?
     A. Win8.1 is not using your 5.1 A/V receiver as the default playback device.

    Technopiper

    Posts : 144
    Join date : 2015-07-30

    Re: Weird problem with sound settings

    Post by Technopiper on Fri Aug 07, 2015 7:06 pm

    lockie wrote:Suppose, this is a system problem. In case u've win 8 may be u need to adjust A/V receiver?
    From FAQ:
    19. Q. I do not hear any sounds, like engines or gunshots. Why?
     A. Win8.1 is not using your 5.1 A/V receiver as the default playback device.
    But I'm not running audio through a receiver, but from the motherboard build-in sound. All sound effects are there, I just couldn't change the speech volume. I even get an audio confirmation [softer/louder] when I adjust the speech slider. Does anyone have the same experience?
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: Weird problem with sound settings

    Post by lockie on Fri Aug 07, 2015 7:24 pm

    Set it up manually:
    ...data\k42\loc_rus\config\config.engcfg
    Code:
    speech_vol=0.390000;

    Technopiper

    Posts : 144
    Join date : 2015-07-30

    Re: Weird problem with sound settings

    Post by Technopiper on Fri Aug 07, 2015 8:20 pm

    lockie wrote:Set it up manually:
    ...data\k42\loc_rus\config\config.engcfg
    Code:
    speech_vol=0.390000;
    I set it to "speech_vol = 0.000000", speech plays in the same volume. I just installed the game on a notebook running Windows 7 SP1 64-bit. Same thing happened. Speech slider doesn't do anything. Could you try setting speech to "0" and see if there's a difference? Is this one of those "placebo feature"? confused
    avatar
    KurtTank
    Silver Tools
    Silver Tools

    Posts : 385
    Join date : 2015-06-11
    Age : 57
    Location : Kalispell, Montana USA

    Re: Weird problem with sound settings

    Post by KurtTank on Sat Aug 08, 2015 6:04 am

    Technopiper wrote:Hi guys, I have a problem setting the speech volume. No matter my setting, in-game speech remains the same. Even when I set it to "0", I can still hear speech at 100% volume. Has anyone noticed that? I tried everything: disabling SSM, even reinstalling. I understand speech can be disabled by renaming the "speech" folder, but I just want to tone down its volume a bit.

    Another related problem. Graviteam says here: http://graviteam.com/forum/index.php?topic=4.0
    "In game options choose "disable sound and music", this also disable subtitles."
    I've found that you can disable subtitle by disabling sound all together. But what if I want to retain sound?
    I have the same problem. Speech is always too loud and annoying...no control at all. Windows 8?
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: Weird problem with sound settings

    Post by frinik on Sat Aug 08, 2015 6:59 am

    Go into your config file: data/k_42/loc_rus/config and check the following entry :

    This is mine and I can adjust the volume both in game and through my pc without any problem. Open the file with note pad and adjust the speech or music volumes at your convenience. Save and exit the file.


    //çâóê
    i_soundman:soundman()
    {
    //óñòðîéñòâî äëÿ âîñïðîèçâåäåíèÿ çâóêà (0 - ïî óìîë÷àíèþ)
    device = 0;
    //êîëè÷åñòâî êàíàëîâ
    channels = 2;
    //÷àñòîòà äèñêðåòèçàöèè
    freq = 44100;
    //áèò íà îòñ÷åò
    bits = 16;
    //ãðîìêîñòü ýôôåêòîâ
    sfx_vol = 1.000000;
    //ãðîìêîñòü ðå÷è
    speech_vol = 0.450000;
    //îáùàÿ ãðîìêîñòü
    global_vol = 1.000000;
    //ãðîìêîñòü ìóçûêè
    music_vol = 0.000000;
    //íåò çâóêà
    no_sound = 0;
    //èñïîëüçîâàòü àïïàðàòíîå óñêîðåíèå
    use_hw_sound = 1;
    //ìàêñèìàëüíîå êîëè÷åñòâî êàíàëîâ (0 - ìàêñèìàëüíîå ïîääåðæèâàåìîå àïïàðàòóðîé)
    max_channels = 0;
    //îòêëþ÷èòü ìóçûêó
    no_music = 0;
    //êà÷åñòâî çâóêà
    snd_qual = 1;

    Technopiper

    Posts : 144
    Join date : 2015-07-30

    Re: Weird problem with sound settings

    Post by Technopiper on Sat Aug 08, 2015 8:51 am

    frinik wrote:Go into your config file: data/k_42/loc_rus/config and check the following entry :

    This is mine and I can adjust the volume both in game and through my pc without any problem. Open the file with note pad and adjust the speech or music volumes at your convenience. Save and exit the file.
    My config file is identical, I even changed the parameters to match yours, didn't help. I tried it on 2 PCs: a desktop running Win 8.1 and a notebook running Windows 7. Both has the same problem with unmodded stock game.

    This isn't a big deal, I am thankful the game runs at all, really had a blast the whole week. It's just that an unsolved mystery bothers me. cyclops Guess I'll just have to put up with LINKS! RECHTS! ACHTUUUUNG!!!!!!! rabbit
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: Weird problem with sound settings

    Post by lockie on Sat Aug 08, 2015 9:56 am

    It's funny, but I can't adjust speech volume either Smile
    I've set it up to "0".
    speech_vol=0.010000;
    I've win xp sp2 and during the game I can hear crew's speech a very well and loud! This game is full of bugs Very Happy
    avatar
    KurtTank
    Silver Tools
    Silver Tools

    Posts : 385
    Join date : 2015-06-11
    Age : 57
    Location : Kalispell, Montana USA

    Re: Weird problem with sound settings

    Post by KurtTank on Sat Aug 08, 2015 10:03 am

    It's funny, but I can't adjust speech volume either Smile
    I've set it up to "0".
    speech_vol=0.010000;
    I've win xp sp2 and during the game I can hear crew's speech a very well and loud! This game is full of
    lockie wrote:bugs Very Happy
    jocolor
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: Weird problem with sound settings

    Post by frinik on Sat Aug 08, 2015 10:05 am

    TRy lowering th speech volume from to //ãðîìêîñòü ðå÷è
    speech_vol = 0.450000; to 0.250000 and save and see if it works. Also can you turn the sound down using your pc controls?

    Technopiper

    Posts : 144
    Join date : 2015-07-30

    Re: Weird problem with sound settings

    Post by Technopiper on Sat Aug 08, 2015 11:17 am

    frinik wrote:TRy lowering th speech volume from to //ãðîìêîñòü ðå÷è
    speech_vol = 0.450000; to 0.250000 and save and see if it works. Also can you turn the sound down using your pc controls?
    I think the global volume control is working correctly, frinik. It's just the speech track that isn't functioning as expected, for some of us at least. I prefer to have the voices drowned-out by gunfires, it's more atmospheric for me. Having a German guy screaming over your every move is a bit anti-climatic. Laughing

    Technopiper

    Posts : 144
    Join date : 2015-07-30

    Re: Weird problem with sound settings

    Post by Technopiper on Sat Aug 08, 2015 11:19 am

    lockie wrote:It's funny, but I can't adjust speech volume either Smile
    I've set it up to "0".
    speech_vol=0.010000;
    I've win xp sp2 and during the game I can hear crew's speech a very well and loud! This game is full of bugs Very Happy
    I am relieved to know that I am not the only one with this problem. Thank you for trying it out for me! And thank you too, KurtTank!

    Sponsored content

    Re: Weird problem with sound settings

    Post by Sponsored content


      Current date/time is Tue Nov 21, 2017 10:31 pm