Latest topics

» The Raging Bull
by woofiedog Today at 2:51 pm

» Errors 98% during mission download
by Kozak76 Today at 11:03 am

» Video from SF
by plug_nickel Yesterday at 12:06 pm

» Українська локалізація/Ukrainian local
by will73 Yesterday at 6:40 am

» black tanks
by eagle64 Tue Sep 19, 2017 10:32 am

» Video Achtung Panzer
by plug_nickel Mon Sep 18, 2017 1:45 pm

» 2.3 sta troubleshooting
by cftaurus Mon Sep 18, 2017 1:27 pm

» Ukraine fights against enemy.
by lockie Sun Sep 17, 2017 5:45 pm

» STA2.3 version
by mechanic Sun Sep 17, 2017 7:26 am

September 2017

MonTueWedThuFriSatSun
    123
45678910
11121314151617
18192021222324
252627282930 

Calendar Calendar


    Object editor dont work

    Share

    jonix007

    Posts : 14
    Join date : 2015-07-22

    Object editor dont work

    Post by jonix007 on Wed Jul 22, 2015 8:00 pm

    Hi , i'm using blender and when i go to export is ok, is X format file, but when i try to open in object editor, dont open why ? thanks Question Crying or Very sad Crying or Very sad
    now only the gun comes why ? i think is the gun ( the tank is js-7)
    http://i18.servimg.com/u/f18/19/27/85/99/sem_ty11.png
    The author of this message was banned from the forum - See the message

    jonix007

    Posts : 14
    Join date : 2015-07-22

    Re: Object editor dont work

    Post by jonix007 on Wed Jul 22, 2015 8:35 pm

    Donken wrote:You must parent/link everything to the hull. Then select only hull and export select. Always export to x format. And in the editor export to go file =)

    Thanks worked! i love u!

    jonix007

    Posts : 14
    Join date : 2015-07-22

    Re: Object editor dont work

    Post by jonix007 on Wed Jul 22, 2015 8:42 pm

    Donken wrote:You must parent/link everything to the hull. Then select only hull and export select. Always export to x format. And in the editor export to go file =)

    Can u help me now? The tank is red, all red. i tried to paint him at blender but i cant, and if object edit i can ?
    The author of this message was banned from the forum - See the message

    jonix007

    Posts : 14
    Join date : 2015-07-22

    Re: Object editor dont work

    Post by jonix007 on Wed Jul 22, 2015 8:55 pm

    Donken wrote:You need to apply a material in the editor. Search for matlib on the forum on how to add your texture in the material library. And in the editor, select everything first. Then go to the panel to the right, go to material tab and choose in the list there.

    Here is a topic you must read, all info you need is here: http://stasf2008.ephpbb.com/t275-vehicles-import-tutorial

    But when i go try , it appear a error and close the editor..
    The author of this message was banned from the forum - See the message
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3642
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: Object editor dont work

    Post by lockie on Wed Jul 22, 2015 9:01 pm

    jonix007 wrote:But when i go try , it appear a error and close the editor..
    Did u follow?
    2.3 Importing models/LOD's
    You should now see your textured model. If it's all red, it's because the material wasn't set properly in the model, make sure you followed the step 1.9. If your 3D studio porks the name of the material, you can change it manually in the SF Object Editor. Click on the "Select all" button, then go the right panel, click on the "materials" tab, browse until you find your new "PANTHER" material, and click the button with the two arrows (top left of the panel) to assign the material to all the selected objects.
    How did u name er new material for the tank? Show me the fragment from:
    ...data\k42\loc_rus\config\matlib.engcfg
    It should look like this:
    Code:

       TANKA44()
       {
          shader = editor;
          textures = tanka44, tanka44_bump, mudnburn;
          parent = TANK;

          diffuse = 1, 1, 1, 1;
          ambient = 0, 0, 0, 0;
          emissive = 0, 0, 0, 0;
          specular = 0.639216, 0.639216, 0.639216, 1;

          power = 32;
          detail_tscale = 0;
          detail_scale = 0;
          bump_scale = 0.7;
          fresnel = 0;


       }// end of tank A-44
    Of course, before applied material u had created the appropriate texture:
    tbump_tanka44_bump_c.dds
    techn_tanka44_c.dds


    Last edited by lockie on Wed Jul 22, 2015 9:08 pm; edited 1 time in total

    jonix007

    Posts : 14
    Join date : 2015-07-22

    Re: Object editor dont work

    Post by jonix007 on Wed Jul 22, 2015 9:06 pm

    lockie wrote:
    jonix007 wrote:But when i go try , it appear a error and close the editor..
    Did u follow?
    2.3 Importing models/LOD's
    You should now see your textured model. If it's all red, it's because the material wasn't set properly in the model, make sure you followed the step 1.9. If your 3D studio porks the name of the material, you can change it manually in the SF Object Editor. Click on the "Select all" button, then go the right panel, click on the "materials" tab, browse until you find your new "PANTHER" material, and click the button with the two arrows (top left of the panel) to assign the material to all the selected objects.

    OK, i dindnt find the "Panther" , but i used the texture of KV1, is so ugly, cause the gun have some bugs, but is okay ,thanks, if i have more questions can i ask here ?
    The author of this message was banned from the forum - See the message

    jonix007

    Posts : 14
    Join date : 2015-07-22

    Re: Object editor dont work

    Post by jonix007 on Wed Jul 22, 2015 9:12 pm

    I'm confuse, i'm following the tutorial of lokie, but i dont know what i do, in my tank i just have "root" in fragments, i'm confuse, ur tutorial looks great, but i'm stuck, what i do first?
    here http://i18.servimg.com/u/f18/19/27/85/99/sem_ty12.png
    and about pivot ? i do in the begin or in the final of the projet of the tnak ?
    The author of this message was banned from the forum - See the message

    jonix007

    Posts : 14
    Join date : 2015-07-22

    Re: Object editor dont work

    Post by jonix007 on Wed Jul 22, 2015 9:29 pm

    how i open ? i didnt seach anything
    The author of this message was banned from the forum - See the message
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3642
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: Object editor dont work

    Post by lockie on Wed Jul 22, 2015 10:06 pm

    I've spent more than one year to get a skill how to put the tank in the game. Even now I need ~ two weeks to do that. And u want to make everything for the one day Smile There is one gold rule - no need to be in hurry.
    The author of this message was banned from the forum - See the message

    Sponsored content

    Re: Object editor dont work

    Post by Sponsored content


      Current date/time is Thu Sep 21, 2017 6:40 pm