Latest topics

» Campaign "Steel Beast" (Pz.V "Panther") WIP
by mechanic Today at 12:29 pm

» Легкий танк Т-50/Light tank T-50
by will73 Yesterday at 10:00 pm

» Танк Пантера Д/А/Г/ Panther ausf.D,A,G
by lockie Yesterday at 5:52 pm

» il2 Sturmovik Stalingrad
by lockie Yesterday at 3:51 pm

» SF STA1.2 demo version?
by woofiedog Sun Nov 19, 2017 3:30 pm

» Video from SF
by geoweb35 Sun Nov 19, 2017 11:24 am

» How to get STA3.2 mod?
by lockie Sat Nov 18, 2017 6:18 pm

» STA(Steel Tank Add-on) 3.2 (Steel Fury)
by lockie Fri Nov 17, 2017 1:42 pm

» The Sun Comes Up, the Sun Goes Down
by woofiedog Thu Nov 16, 2017 9:17 pm

November 2017

MonTueWedThuFriSatSun
  12345
6789101112
13141516171819
20212223242526
27282930   

Calendar Calendar


    WIN 7 64-bit and Steel Sound Mod...

    Share

    p38pilot

    Posts : 17
    Join date : 2014-08-07

    WIN 7 64-bit and Steel Sound Mod...

    Post by p38pilot on Sat Aug 09, 2014 3:27 pm

    lockie,

    Got up this morning and started playing SF. The shader problem was happening again. I did a little trouble-shooting and first tried disabling desktop comp as this worked on an old Battle of Britain flight sim I have. No luck. So, I took your advice and removed the Steel Sound Mod in JSGME. That is another fix for the WIN 7 64-bit memory problem. I think you should place this fix in the FAQ just before the 4GB Patch Fix.

    The problem may vary from PC to PC depending on the users configuration. Each person will have to do their own testing to see what will work for their particular system. If they want to use the Steel Sound Mod they can try the 4GB fix first. Maybe if they have more memory like 16GB instead of the 8GB I have they may not experience this problem.

    I can only surmise that SF 32-bit running on WIN7 as I've stated before is an old program that obviously is not optimized for new 64-bit OS and therefore is not handling the memory correctly. With the Sound Mod active the game was doing all kinds of weird things while running. Sometimes it would automatically exit the game and other times the shader error message would pop up.

    So, the conclusion is using the sound mod in addition to the STA1.0 mod, etc. when running SF uses too much memory in a newer OS and causes problems such as I've experienced. Hope this helps.
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by lockie on Sat Aug 09, 2014 4:18 pm

    p38pilot, u may try to decrease the number of sounds in SSM1.0, i.e. american/german speech and see will it help or not.

    PS
    Or delete the next folders:
    - data\k42\loc_rus\sounds\speech\ger
    - data\k42\loc_rus\sounds\speech\tank

    then install SSM1.0

    p38pilot

    Posts : 17
    Join date : 2014-08-07

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by p38pilot on Sat Aug 09, 2014 4:42 pm

    Thanks lockie, I will give it a shot.
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by frinik on Sun Aug 10, 2014 5:34 am

    Alternately p38pilot you cna try my Speech Lite mod which is only 138 mbs compared to the original 245.I removed all non essential chatter keeping only the commands and instructions that are required for the basic immersion or the mechanics of the game. No more screaming or the AI uttering nonsense at any time.

    Here's the link.
    4shared.com/zip/3vzng2Vyce/speech.html

    The instructions are simple.Just remove all speech folders from your NTA/STA installation and paste mine into the sounds folder.

    p38pilot

    Posts : 17
    Join date : 2014-08-07

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by p38pilot on Sun Aug 10, 2014 2:22 pm

    lockie,
    OK, removing the two folders enables me to use the sound mod without problems. You may want to add this fact to the FAQ in case other users run into this problem. The game is better with the Sound Mod.

    frinik,
    Thanks for the info on the lite mod. I will give it a try too. One question for you both on the Steel Sound Mod: It might be my perception is off, but it seems the sound of the tank's engines should be a little louder in the overall sound atmosphere of the game. Maybe this was done on purpose so as not to drown out all the other sounds?

    Also on the options do you guys recommend using EAX Enabled in SF?
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by lockie on Sun Aug 10, 2014 2:31 pm

    p38pilot wrote:
    OK, removing the two folders enables me to use the sound mod without problems. You may want to add this fact to the FAQ in case other users run into this problem. The game is better with the Sound Mod.
    Excellent news! I think that was the MAIN problem for the English game version, coz game had to keep in PC memory almost TWO times more sounds fragments then default. I'll re-done SSM1.0 with purpose to adjust it exactly to the English game version. Hope in this case we don't need to use 4Gb patch anymore. p38pilot, I'd be pleased, if u test the new version SSM2.0.

    Also on the options do you guys recommend using EAX Enabled in SF?
    EAX means enhanced? Could u enclose screen?
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by frinik on Sun Aug 10, 2014 2:37 pm

    I use EAX although I am not sure it makes much difference in the quality of the sound to be honest.
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by lockie on Sun Aug 10, 2014 2:43 pm

    Just tested SSM2.0 with adjusting to English version and it's not good. So, the there will be note:
    Owners of the English game version MUST delete two folders:
    - data\k42\loc_rus\sounds\speech\ger
    - data\k42\loc_rus\sounds\speech\tank

    then install SSM1.0
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by frinik on Sun Aug 10, 2014 2:51 pm

    I have some new ( more powerful) engine sounds which I will provide to Comrade Lockie for his next update....

    p38pilot

    Posts : 17
    Join date : 2014-08-07

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by p38pilot on Sun Aug 10, 2014 3:37 pm

    I'm going to try using EAX enabled in my next SF session but like frinik says it probably won't make much difference. Generally it's supposed to allow your system to run more efficently, especially as far as memory is concerned. I've found over the years that in many games that have this option it sometimes makes a difference and sometimes not. So, its' basically a roll of the dice in this regard.

    lockie,
    In my English version I think the EAX option is a check box on the Sound Options page.

    Part of the reason I asked about the engine sound was I was thinking there might be a config folder in the SF program where you could adjust individual sounds to the users personal preference.
    avatar
    frinik
    TSF Member-Golden Feather
    TSF Member-Golden Feather

    Posts : 1396
    Join date : 2014-07-27
    Age : 61
    Location : Abu Dhabi-UAE

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by frinik on Mon Aug 11, 2014 4:57 am

    There's a config folder but while you cna tinker wiht the graphic options/rendering you can't unfortunately do the same with the individual sounds.
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by lockie on Tue Aug 12, 2014 5:31 pm

    p38pilot wrote:
    In my English version I think the EAX option is a check box on the Sound Options page.
    Part of the reason I asked about the engine sound was I was thinking there might be a config folder in the SF program where you could adjust individual sounds to the users personal preference.
    In my config EAX is always checked. There's file:
    ...data\k42\loc_rus\config\config.engcfg
    where u can adjust some parameters, which are none documented, but be careful. It's a very easy to spoil config.

    Txema
    TSF Member
    TSF Member

    Posts : 258
    Join date : 2014-07-26

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by Txema on Wed Aug 13, 2014 5:30 pm

    I think that EAX effects don't work in Windows 7. However, at least for soundblaster sound cards, you can install an application called "Alchemy" from Creative, that allows to have EAX effects in Windows 7.


    Txema
    avatar
    javelina

    Posts : 14
    Join date : 2014-11-26

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by javelina on Wed Nov 26, 2014 4:21 am

    Hello group,

    I've current have the following mods installed, and I installed them in the order that was defined by lockie.

    SSM 1.0
    GMP 1
    GMP 2
    GMP 3
    STA 1.0
    SepUPD_2014

    I've also deleted the Ger & Tank sound folders.

    My problem is that I don't hear any of tank engine sounds. I can hear my tank commander call out commands, but I hear no engine sounds. Would appreciate any suggestions.

    my system:
    - Win8.1
    - SF is installed at E:\games\steel_fury
    - followed lockie's install instructions

    regards,

    -Jav

    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by lockie on Wed Nov 26, 2014 7:40 am

    Hi, Jav
    That's a new bug, which I've never met. Try to play with sound options, i.e. disable "hardware acceleration", "quality sound".
    I think that's a problem with direct x. SF was made on the base of direct x 9.
    avatar
    javelina

    Posts : 14
    Join date : 2014-11-26

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by javelina on Wed Nov 26, 2014 7:45 am

    Hi Lockie,  I'll try that in the morning (here in the USA).  then report back.  Getting late here, but I appreciate the help.

    I'll report back soon.  

    -Jav
    avatar
    javelina

    Posts : 14
    Join date : 2014-11-26

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by javelina on Wed Nov 26, 2014 7:47 am

    I've had hardware acceleration turned off, and quality sound on. I'll turn off quality sound to off and report back.

    thanks again.

    -Jav
    avatar
    javelina

    Posts : 14
    Join date : 2014-11-26

    WIN 7 64-bit and Steel Sound Mod 2

    Post by javelina on Wed Nov 26, 2014 5:28 pm

    lockie wrote:Hi, Jav
    That's a new bug, which I've never met. Try to play with sound options, i.e. disable "hardware acceleration", "quality sound".
    I think that's a problem with direct x. SF was made on the base of direct x 9.

    Hi lockie,

    I've disabled "hardware acceleration" and "quality sound".  I still do not hear any of the tank engine sounds.  I do hear the tank commander calling out commands though.

    Here's my system info:

    - Win 8.1 pro
    - nVidia GTX 970
    - 16GB RAM
    - Asus Xonar DG sound card

    I have SF installed at E:\games\steel fury

    and I have installed as:

    1. Steel Sound Mod 1.0 (SSM)
    2. STA 1.0
    3. GMP1.21
    4. GMP2.x
    5. GMP3.x
    6. SepUpd_2014

    kind regards,

    -Jav
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3726
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by lockie on Wed Nov 26, 2014 6:17 pm

    It is a very interesting bug Smile
    In fact, both sounds speech and tank`s engine has the same format PCM *.wav, but for some reasons u can't hear roar of the engine.
    Let's start from the beginning. Can u play some sounds from this folder? I'm using Winamp player.

    ...\data\k42\loc_rus\sounds\engines\

    PS
    Perhaps, u didn't install properly SSM (STA) 1.0 mod.
    For any case, this is folder JSGME in the directory of SF:
    ...Steel Fury - Kharkov 1942\MODS\


    This is content of the folder SSM (STA) 1.0, if u open it.


    Does it look similar to er installation? Coz may be u've mistake of "double folder" after unpacked the archive.
    avatar
    javelina

    Posts : 14
    Join date : 2014-11-26

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by javelina on Wed Nov 26, 2014 6:27 pm

    lockie wrote:It is a very interesting bug Smile
    In fact, both sounds speech and tank`s engine has the same format PCM *.wav, but for some reasons u can't hear roar of the engine.
    Let's start from the beginning. Can u play some sounds from this folder? I'm using Winamp player.

    ...\data\k42\loc_rus\sounds\engines\

    PS
    Perhaps, u didn't install properly SSM (STA) 1.0 mod.
    For any case, this is folder JSGME in the directory of SF:
    ...Steel Fury - Kharkov 1942\MODS\


    This is content of the folder SSM (STA) 1.0, if u open it.


    Does it look similar to er installation? Coz may be u've mistake of "double folder" after unpacked the archive.

    Hi lockie,

    I've double checked, and I do not have the "double folder". (I had that issue once before, in another sim). Always good to double check.

    Now this is weird. I'm able to go into the sounds\speech\tank_ger and can use the Windows media player, and here the german voices. But when I attempt to play any of the .wav files in the other sound folders, I get nothing....

    maybe my SSM file is corrupted? I'll attempt another download, and will report back.

    thx.

    -Jav
    avatar
    javelina

    Posts : 14
    Join date : 2014-11-26

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by javelina on Wed Nov 26, 2014 6:31 pm

    cr*p! I can't download the SSM from the 4shared site. It says I've met my download quota.

    So I'll hunt around elsewhere on the Internet, to see if I can find another copy to download.
    avatar
    javelina

    Posts : 14
    Join date : 2014-11-26

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by javelina on Wed Nov 26, 2014 7:02 pm

    I managed to download the SSM, and reinstalled. But still have the same issue: I'm able to go into the sounds\speech\tank_ger and can use the Windows media player, and hear the german voices. But when I attempt to play any of the .wav files in the other sound folders, I get nothing....

    This really puzzling...
    avatar
    javelina

    Posts : 14
    Join date : 2014-11-26

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by javelina on Wed Nov 26, 2014 8:38 pm

    ok, found the issue. Win8.1 was not picking up my 5.1 A/V receiver as the default playback device. I corrected that, and now SF is sounding great!

    thanks, (and sorry for the trouble).

    -Jav

    Sponsored content

    Re: WIN 7 64-bit and Steel Sound Mod...

    Post by Sponsored content


      Current date/time is Tue Nov 21, 2017 8:02 pm