January 2018

MonTueWedThuFriSatSun
1234567
891011121314
15161718192021
22232425262728
293031    

Calendar Calendar


    Directional Control Issue

    Share

    dwain7

    Posts : 95
    Join date : 2016-04-12

    Directional Control Issue

    Post by dwain7 on Tue Jan 09, 2018 12:01 am

    I have over time encountered an issue with the player tank's directional control (left, right, forward, reverse, and stop) in just a small number of missions. Short stop control is not affected I've seen this in STA 3.1 and now, again, in STA 3.2.affected. A couple of STA 3.2 mission examples are: GMP 1.x, mission 18 (Chernogostie) and GMP 2.x , mission 07 (A Miracle Weapon).

    In both missions, the mission loads normally and everything seems OK until I begin forward movement. I usually move quickly from the commander position (my default) to the gunner's position and fire and maneuver from there, using both the external camera and the sight view. Either immediately or very shortly after moving forward the player tank stops responding to my directional inputs. It's like the tank has a mind of its own. The full stop function disappears altogether, reverse refuses to reverse, and left/right commands are quickly rejected as the tank just moves on its own course. I'm using Win10, fully up to date and a Logitech Extreme joystick. I know the game is not optimized for a joystick, but the same problem happens with keyboard directional commands too. So I don't think the game controller devices (keyboard, joystick) are the issue.

    I am wondering if any of you out there have seen this problem yourselves. And if so, were you able to resolve it?

    Lightning62

    Posts : 45
    Join date : 2016-12-21

    Re: Directional Control Issue

    Post by Lightning62 on Tue Jan 09, 2018 2:51 pm

    Hi,
    I have little similar problem too. When I played training mission with STA.3.2 (Kazan, driver) after first missioon point "Paved road" I must by instructions slow down/break. I was doing so and acceleration (RPM) tab goes empty. And after this acceleration (forward) stopped to work. It happen 5 times.
    I tried this mission also in basic game. There all work fine. Acceleration never disappear and auto gearbox work too. I´m using Win7 fully up to date. My laptop is old but it cant be laptop error. Original same training versioon (without mods) work well without problems.

    With regards
    Lightning62



    Tanker
    TSF Member
    TSF Member

    Posts : 383
    Join date : 2014-07-27

    Re: Directional Control Issue

    Post by Tanker on Wed Jan 10, 2018 12:19 am

    Disconnect your joystick and see if the problem goes away. If it does it is a conflict with the JS and this old game software.

    dwain7

    Posts : 95
    Join date : 2016-04-12

    Re: Directional Control Issue

    Post by dwain7 on Wed Jan 10, 2018 1:09 am

    Tanker said...."Disconnect your joystick and see if the problem goes away. If it does it is a conflict with the JS and this old game software." Believe me, Tanker, I have tried that multiple times. Do not think it is the joystick or its connection since the same problem occurs with the similar keyboard command inputs.
    avatar
    lockie
    TSF Member
    TSF Member

    Posts : 3828
    Join date : 2014-07-24
    Age : 50
    Location : Ukraine, Kyiv

    Re: Directional Control Issue

    Post by lockie on Wed Jan 10, 2018 9:14 am

    That's because of the tricky script Smile
    Will be fixed in JAN upd 2018. Training mission with a driver works fine already.

    dwain7

    Posts : 95
    Join date : 2016-04-12

    Re: Directional Control Issue

    Post by dwain7 on Thu Jan 11, 2018 1:59 am

    Thank you Lockie, I look forward to the January update.

    Best...
    avatar
    mechanic

    Posts : 185
    Join date : 2014-11-03
    Age : 54

    Re: Directional Control Issue

    Post by mechanic on Thu Jan 11, 2018 10:48 am

    I resolved this issue took the driver's place and gave a command "Do as I do".

    dwain7

    Posts : 95
    Join date : 2016-04-12

    Re: Directional Control Issue

    Post by dwain7 on Mon Jan 15, 2018 10:39 pm

    After a short series of PMs with Lockie, I was able to resolve my problem with STA 3.3.

    I deactivated all mods after the ploygons mod. Then I reinstalled and reactivated STA 3.3, the January update, etc. However, it is extremely important to follow the mod activation procedure that Lockie has posted absolutely to the letter. When it says run the 4 Gb Patch right after activating STA 3.3, that is what you need to do. When it says "create a new user profile" the first time you run the game after activating the 16-9 aspect mod, that is what you need to do. Do not second guess the procedure, just be disciplined and linear in your approach.

    Many thanks to Lockie for his guidance and assistance. I have seen a noticeable improvement with the advent of STA 3.3 and the January 2018 update. It also resolved my directional control issues I had recently posted separately about.

    Sponsored content

    Re: Directional Control Issue

    Post by Sponsored content


      Current date/time is Fri Jan 19, 2018 12:27 pm